Wrong sensor_id in gear file produced by LCIOWriter

Dear all,
I am running an example of mimosa telescope (6 m26 planes) plus 3 DUTs and using LCIOWriter to dump slcio and gear file.
What I don’t understand concerns the output gear file gear.conf (6.9 KB) (renamed to .conf to make upload possible): the IDs are not the ones I have declared in the conf files (you can find them heremimosa_telescope_with_dut.conf (1.8 KB) mimosa_precise_dut.conf (1.5 KB). mimosa_precise_dut.conf is the main conf file and you can see which are the sensor IDs I have declared:


I run the simulation like this:
bin/allpix -c examples/precise_dut/mimosa_precise_dut.conf

Any help will be greatly appreciated.

Best regards,
Marco Bomben

Dear @mbomben

I have tested this with your configuration files and found that the reason is simply a typo in your configuration file (detector_assignement vs detector_assignment) - which that fixed it works as expected.

I will add a few lines of logging output to the module so it will be easier to spot this in the future.


Oh, my bad! Thanks a lot @simonspa for spotting this - and solve the issue!