pyROOT: dictionary for allpix::MCParticle missing

new Allpix Squared user here. I installed both ROOT and Allpix Squared today which was surprisingly easy (thanks!). I am running into an issue with the tools/root_analysis_macros example in python, though. I used the eudet_rd53a example with the provided configuration (except reducing the number of events to 100 for speed and file size and disabling the LCIOWriter) and let Allpix do its job.
From a root browser the output file structure looks good, except I can not run the tools/root_analysis_macro/ example with pyROOT complaining

Error in <TClass::LoadClassInfo>: no interpreter information for class allpix::MCParticle is available even though it has a TClass initialization routine.

and in fact spamming my terminal with this message until I stop the process with Ctrl-Z

I add the path to the as argument to the script, but somehow python can not understand the MCParticle class. System information:

Allpix Squared version v2.0.0-686-gf2d12a42
               built on 2022-02-16, 16:33:56 UTC
               using Boost.Random 1.77.0
                     ROOT 6.24/06
                     Geant4 1100

I am not experienced with ROOT itself or C++, but following the readme file in tools/root_analysis_example for Analysis Example also throws a few errors in the ROOT CLI.
Is there some obvious mistake that I am making? Let me know if you need more information.

Hi @cbespin,

I have noticed the same problem as well, and it seems to be inherent in the latest version of allpix squared (Allpix^2 v2.0.0-686-gf2d12a42). By running on an older version of AllpixSquared (e.g. 2.0.3), the problem disappears, at least for me. So, I guess you should install an older version for now and work with that.



Hi @cbespin ,

welcome to the user community!

Thanks for spotting and reporting this. I can reproduce this, but could not fix it right now. I thus filed an issue via our gitlab repository, so we will address this soon:

I can report that in version v2.0.3 it does still work - just in case this is helpful to you for now. I did not try it out with versions v2.1.x yet. (@Andrew was faster than me… :slight_smile: )

We will come back to you once this is fixed.


1 Like

Thanks for the replies @Andrew and @pschutze,
I was about to reply as well, because I tried the latest stable release (2.1.1 as far as I can see) in the meantime and it works beautifully there. Nothing to worry about in the release channel at least. I will keep an eye on the issue and see if I can help somehow.


1 Like

Hi @cbespin , @Andrew ,

we identified the issue and fixed it, see this MR: Fix object dependency on text-util (!683) · Merge requests · Allpix Squared / Allpix Squared

Thanks again for reporting it! The MR is already merged and included in master by now. We would be grateful if you could check out the latest master and confirm that this indeed fixes the issue.

Thanks again for spotting and reporting this!


1 Like

Hi @pschutze,

I just installed from master and can confirm that it works now. Thanks!

Perfect, thanks a lot!

1 Like