Issue with mesh converter (remains hung at 5%)

Dear Allpix-squared staff,

I encountered an issue when trying to convert my TCAD Electric fields with the mesh converter. The conf file I am using is this one:

model = “apf”
dimension = 3
region = “substrate”
observable = “ElectricField”
divisions = 100 100 100
xyz = z x y

As soon as the interpolation process arrives at 5%, the process remains hung for many hours with no advancement. I tried to reduce the initial radius to initial_radius = 0.0001, but the situation does not improve. I also tried on different machines, with the same outcome. What could the problem be? Here’s a screenshot of what happens:

Could this be a result of a too fine TCAD mesh in the region of the collection electrode and implants? (This refers to monolithic pixels).

Thank you for your support,

Hi @ldecilla

have you tried running the tool with a higher verbosity level like DEBUG to check what the issue might be? It is quite tricky sometimes to find the proper start values for the interpolation, especially when the initial mesh is very irregular.


Dear @simonspa,

thanks for your hint! I ran the mesh_converter with fewer nodes and with DEBUG verbosity level, and I saw that it was actually going on, but extremely slowly. So I produced new TCAD field maps with a coarser mesh in order to gain in conversion speed. This worked.

Thanks again for your support,