Could not find 'timepix'

Greetings! I have successfully compiled and installed Allpix. However when I am trying to run an small simulation with timepix it gives me an error.
(Error during execution of run:
Could not find a detector model of type ‘timepix’
Please check your configuration and modules. Cannot continue.)

I checked that my Models folder does contain timepix.conf, I also tried coping the timepix.conf file from Models to the Modules folder in /source/src/ and it did not work.

INPUT FILES

 [Allpix] 
number_of_events = 1000 
detectors_file = "tutorial-geometry.conf"
log_level = "Warning"

[GeometryBuilderGeant4]

[DepositionGeant4]
particle_type = "Pi+"
source_energy = 120GeV
source_type = "beam"
beam_size = 3mm
source_position = 0um 0um -200mm
beam_direction = 0 0 1 
physics_list = FTFP_BERT_EMZ

[ElectricFieldReader]
model="linear"
bias_voltage=-50V
depletion_voltage=-30V
outpur_plots = 1

[ProjectionPropagation]
temperature = 293K
outpur_plots = 1

[SimpleTransfer]
outpur_plots = 1

[DefaultDigitizer]
outpur_plots = 1

[detector1]
type = "timepix"
position = 0mm 0mm 0mm
orientation = 0 0 0

I believe that my input files are correct.

I have also attached my cmake command results are below. In this file everything builds perfectly.

I really appreciate all your help in this regard. Can you please let me know how to rectify this error.

sanchit@KRATOS:~/Softwares/ALLPIX/build$ cmake -DCMAKE_INSTALL_PREFIX=/home/sanchit/Softwares/ALLPIX/Install -DCMAKE_PREFIX_PATH=/home/sanchit/Softwares/LCIO/Install -DBUILD_ALL_MODULES=ON /home/sanchit/Softwares/ALLPIX/source
-- Git project directory is dirty:
 fatal: not a git repository (or any of the parent directories): .git.
-- Building Allpix^2 version v1.3+101^gc0bafb5e.
-- Building "RelWithDebInfo"
-- Found Doxygen: /usr/bin/doxygen (found version "1.8.13") found components:  doxygen dot 
-- Found LATEX: /usr/bin/latex   
-- Found LaTeX compiler.
-- Found UnixCommands: /bin/bash  
-- Manual: adding 17 module descriptions
-- Manual: adding 7 example descriptions
-- The CXX compiler identification is GNU 7.3.0
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Performing Test CXX_FLAG_WORKS__pedantic
-- Performing Test CXX_FLAG_WORKS__pedantic - Success
-- Performing Test CXX_FLAG_WORKS__Wall
-- Performing Test CXX_FLAG_WORKS__Wall - Success
-- Performing Test CXX_FLAG_WORKS__Wextra
-- Performing Test CXX_FLAG_WORKS__Wextra - Success
-- Performing Test CXX_FLAG_WORKS__Wcast_align
-- Performing Test CXX_FLAG_WORKS__Wcast_align - Success
-- Performing Test CXX_FLAG_WORKS__Wcast_qual
-- Performing Test CXX_FLAG_WORKS__Wcast_qual - Success
-- Performing Test CXX_FLAG_WORKS__Wconversion
-- Performing Test CXX_FLAG_WORKS__Wconversion - Success
-- Performing Test CXX_FLAG_WORKS__Wuseless_cast
-- Performing Test CXX_FLAG_WORKS__Wuseless_cast - Success
-- Performing Test CXX_FLAG_WORKS__Wctor_dtor_privacy
-- Performing Test CXX_FLAG_WORKS__Wctor_dtor_privacy - Success
-- Performing Test CXX_FLAG_WORKS__Wzero_as_null_pointer_constant
-- Performing Test CXX_FLAG_WORKS__Wzero_as_null_pointer_constant - Success
-- Performing Test CXX_FLAG_WORKS__Wdisabled_optimization
-- Performing Test CXX_FLAG_WORKS__Wdisabled_optimization - Success
-- Performing Test CXX_FLAG_WORKS__WformatE2
-- Performing Test CXX_FLAG_WORKS__WformatE2 - Success
-- Performing Test CXX_FLAG_WORKS__Winit_self
-- Performing Test CXX_FLAG_WORKS__Winit_self - Success
-- Performing Test CXX_FLAG_WORKS__Wlogical_op
-- Performing Test CXX_FLAG_WORKS__Wlogical_op - Success
-- Performing Test CXX_FLAG_WORKS__Wmissing_declarations
-- Performing Test CXX_FLAG_WORKS__Wmissing_declarations - Success
-- Performing Test CXX_FLAG_WORKS__Wmissing_include_dirs
-- Performing Test CXX_FLAG_WORKS__Wmissing_include_dirs - Success
-- Performing Test CXX_FLAG_WORKS__Wnoexcept
-- Performing Test CXX_FLAG_WORKS__Wnoexcept - Success
-- Performing Test CXX_FLAG_WORKS__Wold_style_cast
-- Performing Test CXX_FLAG_WORKS__Wold_style_cast - Success
-- Performing Test CXX_FLAG_WORKS__Wredundant_decls
-- Performing Test CXX_FLAG_WORKS__Wredundant_decls - Success
-- Performing Test CXX_FLAG_WORKS__Wsign_conversion
-- Performing Test CXX_FLAG_WORKS__Wsign_conversion - Success
-- Performing Test CXX_FLAG_WORKS__Wsign_promo
-- Performing Test CXX_FLAG_WORKS__Wsign_promo - Success
-- Performing Test CXX_FLAG_WORKS__Wstrict_null_sentinel
-- Performing Test CXX_FLAG_WORKS__Wstrict_null_sentinel - Success
-- Performing Test CXX_FLAG_WORKS__Wstrict_overflowE5
-- Performing Test CXX_FLAG_WORKS__Wstrict_overflowE5 - Success
-- Performing Test CXX_FLAG_WORKS__Wswitch_default
-- Performing Test CXX_FLAG_WORKS__Wswitch_default - Success
-- Performing Test CXX_FLAG_WORKS__Wundef
-- Performing Test CXX_FLAG_WORKS__Wundef - Success
-- Performing Test CXX_FLAG_WORKS__Werror
-- Performing Test CXX_FLAG_WORKS__Werror - Success
-- Performing Test CXX_FLAG_WORKS__Wshadow
-- Performing Test CXX_FLAG_WORKS__Wshadow - Success
-- Performing Test CXX_FLAG_WORKS__Wformat_security
-- Performing Test CXX_FLAG_WORKS__Wformat_security - Success
-- Performing Test CXX_FLAG_WORKS__Wdeprecated
-- Performing Test CXX_FLAG_WORKS__Wdeprecated - Success
-- Performing Test CXX_FLAG_WORKS__fdiagnostics_colorEauto
-- Performing Test CXX_FLAG_WORKS__fdiagnostics_colorEauto - Success
-- Performing Test CXX_FLAG_WORKS__Wheader_hygiene
-- Performing Test CXX_FLAG_WORKS__Wheader_hygiene - Failed
-- NOT adding -Wheader-hygiene to CXX_FLAGS - unsupported flag
-- Performing Test CXX_FLAG_WORKS__Wno_overloaded_virtual
-- Performing Test CXX_FLAG_WORKS__Wno_overloaded_virtual - Success
-- Performing Test SUPPORT_STD_CXX17
-- Performing Test SUPPORT_STD_CXX17 - Success
-- Looking for C++ include pthread.h
-- Looking for C++ include pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Found /usr/bin/clang-format-6.0, adding formatting targets
-- Could NOT check for clang-tidy, wrong compiler: GNU
-- Building module: CapacitiveTransfer
-- Building module: CorryvreckanWriter
-- Building module: DefaultDigitizer
-- Building module: DepositionGeant4
-- Building module: DetectorHistogrammer
-- Building module: Dummy
-- Building module: ElectricFieldReader
-- Building module: GenericPropagation
-- Building module: GeometryBuilderGeant4
-- Geometry export in GDML format is enabled.
-- Building module: LCIOWriter
-- Check for LCIO (2.12.1)
-- Check for LCIO_LIBRARIES: lcio;sio
-- Check for LCIO_LCIO_LIBRARY: /home/sanchit/Softwares/LCIO/Install/lib/liblcio.so -- ok
-- Check for LCIO_SIO_LIBRARY: /home/sanchit/Softwares/LCIO/Install/lib/libsio.so -- ok
-- Found LCIO: /home/sanchit/Softwares/LCIO/Install  
-- Building module: MagneticFieldReader
-- Building module: ProjectionPropagation
-- Building module: RCEWriter
-- Building module: ROOTObjectReader
-- Building module: ROOTObjectWriter
-- Building module: SimpleTransfer
-- Building module: TextWriter
-- Building module: VisualizationGeant4
-- Unit tests: 26 examples
-- Unit tests: 33 module functionality tests
-- Unit tests: 4 performance tests
-- Unit tests: 21 framework core functionality tests
-- Configuring done
-- Generating done
-- Build files have been written to: /home/sanchit/Softwares/ALLPIX/build

Hi all I also tries copying and pasting timepix.conf at the location of my input file it still tells me bellow error:

FATAL ERROR: Could not find a detector model of type ‘timepix’.

It is really important for my project that I resolve this ASAP. Hence I appreciate any help I can get.

Many thanks!

This should just work fine, however it might be that some configuration path was set incorrectly as you are not running cmake the same way as documented in the manual. As said it should then still work, but following the manual closely should help prevent getting into unexpected situations.

Anyway you should be able to workaround this issue by setting the model path manually to the path where the models are located using the model_paths parameters as documented here.

We should check what goes wrong in the CMake installation here. Could you maybe post the output of your

$ make install

command for reference?

@kwolters I can reproduce this by installing in a non-standard location, issue filed here: https://gitlab.cern.ch/allpix-squared/allpix-squared/issues/151

Thanks a lot however I solved this problem as per the guidance of Dr. Wolters I just used the model_paths to get this done. My runs are fine now.

Thanks

Thanks for letting us know! We’ll follow up on the issue independently of this, thank you for reporting!

To follow up on this: this has been fixed in master


and will also be part of 1.3.2.